[microformats-discuss] a micro micro-format for an' item'
ssriram at gmail.com
Thu Oct 13 13:18:41 PDT 2005
From: "Danny Ayers" <danny.ayers at gmail.com>
>But I think in the context of microformats this is almost certainly a
>bad idea. An item in the blog-post definiton will mean a blog-post
>item, never a product item. If you only had generic-item, then you've
>lost a useful chunk of semantics.
You wouldn't 'only' have a generic-item, you would have a
'generic-item' + 'as amany particular elements for the
specific item as you need'
>However this will have the RDF mapping, and in systems that understand
>that model it will be straightforward to say that:
>blogpost:item rdfs:subClassOf generic:item .
>product:item rdfs:subClassOf generic:item .
>blogpost:title rdfs:subPropertyOf generic:title .
>product:title rdfs:subPropertyOf generic:title .
Well than if you were able to map than what differs is merely
the naming convention and not the conceptual aspect of
If that were to be the case than why not settle on a
common naming convention (where possible & applicable)
for the core elements of a generic item ?
The argument you make for this is not to have a
>premature commitment to any kind of top-down semantics.
What if there at least existed 'a suggested' guideline rather
than an enforced commitment ?
More information about the microformats-discuss