[uf-new] collection-design-pattern proposal

Scott Reynen scott at makedatamakesense.com
Mon Apr 23 06:13:39 PDT 2007

On Apr 23, 2007, at 12:12 AM, Manu Sporny wrote:

> <div id="ktsampler" class="haudio">
>    <div id="ktsampler.bh" class="haudio">
>    </div>
> </div>

What's wrong with this:

<div class="audio-album">
	<div class="audio-track">

It seems to me a collection pattern is solving a problem we could  
avoid better by using more specific class names.  In this case,  
tracks and albums are two different things, so they should have two  
different class names.  Albums contain tracks by definition, so no  
need for additional semantics here, right?

Scott Reynen

More information about the microformats-new mailing list