[uf-new] hAudio proposal: ITEM/TRACK

Scott Reynen scott at makedatamakesense.com
Sun Oct 14 14:56:05 PDT 2007

On Oct 14, 2007, at 2:01 PM, Manu Sporny wrote:

> We need some sort of "container" to hold track/song information in an
> hAudio album. The contents of this "container" will be another hAudio
> chunk or text (which will be the FN of an hAudio object).

I hope this doesn't complicate matters further, but the way Manu  
phrased this gave me an idea for a third solution to this problem:  
use class="haudio" alone.  Any hAudio without an album property is  
already assumed to be a single track.  If the only reason we're  
specifying this with an additional class name of "track" or "item" is  
to allow for track listings in name-only shorthand, why don't we just  
allow that shorthand with hAudio itself?  I.e. make the following  
semantically identical:

<span class="haudio"><span class="fn">My Way</span></span>
<span class="haudio">My Way</span>

That would remove the need for an additional class name, and also  
make it easier for publishers to use hAudio in its minimal form even  
without surrounding albums.  This would be somewhat similar to  
hCard's implied n optimization, only simpler.

One drawback: this would make it impossible to use hAudio markup for  
a song mentioned in the context of an album that is not a track of  
that album.  The song could still be mentioned, just not marked up  
with hAudio without implying it's a track of the surrounding album.   
I'm not sure whether or not that's common enough to be a reason for  
using another class name.

Scott Reynen

More information about the microformats-new mailing list