[uf-new] Recipe status

Thomas Yde thomasyde at yahoo.dk
Sun Apr 20 08:42:57 PDT 2008

Toby A Inkster wrote:

> I suggest that (where there is an overlap) we take class names from  
> hAtom. This will allow easy overlapping between the formats for  
> pages that feature a collection of recipes. e.g.
> 	<div class="hatom hrecipe">
> 		...
> 	</div>
> even, say:
> 	<div class="hatom hrecipe hslice">
> 		...
> 	</div>
> For Internet Explorer 8 fun!
> So, as amendments to Thomas' proposal, I'd like to see:
> 	* Replace class="title" with class="entry-title"
> 	* Replace class="summary" with class="entry-summary"
> 	* Replace class="dtpublished" with class="published"
> I realise you've already tried to take class names from hReview,  
> but I think hAtom is a better match. Other than that, I like the  
> schema proposed.

Reusing class names from hatom seems logical to me as recipes have  
more in common with that format than hreview.

> Regarding the relationship with the measure microformat, which I've  
> been trying to push forward with a bit (I wrote most of the current  
> draft schema), I don't think we need to wait for it. We should  
> basically say that the class="quantity" element contains a free- 
> form string. For any future parsers that do implement a measurement  
> microformat, then a bit of mix and match will be perfectly  
> acceptable -- but parsers which understand hrecipe and not hmeasure  
> can just interpret the quantity as a string and that should be  
> considered acceptable behaviour. So in short, we *allow* for a  
> future measurement microformat to optionally be hooked in to  
> hrecipe, but in general we just treat quantities as a string.
> 	<li class="ingredient hmeasure">
> 		<span class="quantity">
> 			<span class="value">2</span>
> 			<span class="unit">tbsp</span>
> 		</span>
> 		<span class="item">parsley</span>
> 		<span class="preparation-note">(chopped)</span>
> 	</li>
> would be parsed by an hrecipe aware parser as:
> 	Ingredient:
> 		Quantity: 2 tbsp
> 		Item: parsley
> 		Preparation Note: (chopped)
> and by an hmeasure aware parser as:
> 	Measurement:
> 		Value: 2
> 		Unit: tbsp
> 		Item: parsley
> A parser aware of both could combine this information logically.

I agree that hmeasure can eventually be hooked into hrecipe and that  
we don't need to wait for hmeasure.

> Also, I'm beginning to think that class="value" is a poor choice of  
> class name for hmeasure, given its "special behaviour" in value  
> excerpting. Should it be class="num", class="val" or something?

Why do you think 'value' is a poor class name? Can you elaborate a  
bit on the "special behaviour"?


More information about the microformats-new mailing list