[uf-new] Recipe status
Toby A Inkster
mail at tobyinkster.co.uk
Sun Apr 20 08:02:43 PDT 2008
I suggest that (where there is an overlap) we take class names from
hAtom. This will allow easy overlapping between the formats for pages
that feature a collection of recipes. e.g.
<div class="hatom hrecipe">
<div class="hatom hrecipe hslice">
For Internet Explorer 8 fun!
So, as amendments to Thomas' proposal, I'd like to see:
* Replace class="title" with class="entry-title"
* Replace class="summary" with class="entry-summary"
* Replace class="dtpublished" with class="published"
I realise you've already tried to take class names from hReview, but
I think hAtom is a better match. Other than that, I like the schema
Regarding the relationship with the measure microformat, which I've
been trying to push forward with a bit (I wrote most of the current
draft schema), I don't think we need to wait for it. We should
basically say that the class="quantity" element contains a free-form
string. For any future parsers that do implement a measurement
microformat, then a bit of mix and match will be perfectly acceptable
-- but parsers which understand hrecipe and not hmeasure can just
interpret the quantity as a string and that should be considered
acceptable behaviour. So in short, we *allow* for a future
measurement microformat to optionally be hooked in to hrecipe, but in
general we just treat quantities as a string.
<li class="ingredient hmeasure">
would be parsed by an hrecipe aware parser as:
Quantity: 2 tbsp
Preparation Note: (chopped)
and by an hmeasure aware parser as:
A parser aware of both could combine this information logically.
Also, I'm beginning to think that class="value" is a poor choice of
class name for hmeasure, given its "special behaviour" in value
excerpting. Should it be class="num", class="val" or something?
Toby A Inkster
<mailto:mail at tobyinkster.co.uk>
More information about the microformats-new